jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcel Reutegger <marcel.reuteg...@gmx.net>
Subject Re: problem configurating index jackrabbit
Date Mon, 07 Sep 2009 07:05:13 GMT
Hi,

first of all, are you sure the configuration is actually used by the
index? correct parameter in workspace.xml, no errors in the logs?

then a general note on the indexing configuration: you cannot exclude
nodes entirely from being indexed. an index-rule just allows you to
strip down indexing to a bare minimum for certain nodes. that is, its
type and reference to its parent.

also note that the index will pick the first rule that matches. does
th:plainDocument inherit from any of the node types in the preceding
index-rules? if that's the case, then it will never be used because
the preceding rule will be picked instead.

regards
 marcel

2009/9/4 Ana.Radu <Ana.Radu@sdc.ro>:
>
> Hello,
>
> i need a little help
>
> i'm just a junior developer and right now i have to work with jackrabbit..
> i have a little problem with configuration of indexing, and i read something about it
on wiki and read some comments, but i can't find a solution.
> i've configured a repository with my own types of node with namespace "th", and when
i try to index some nodes my indexing-configuration are ignored! i don't know why (i try to
play with default nodes and it realy work, but with my custom nodes no).
>
> this is my indexing-configuration:
>
> <?xml version="1.0"?>
> <!DOCTYPE configuration SYSTEM "http://jackrabbit.apache.org/dtd/indexing-configuration-1.0.dtd">
> <configuration xmlns:jcr="http://www.jcp.org/jcr/1.0"
>              xmlns:th="http://www.sdc.ro/thoth/1.0"
>            xmlns:nt="http://www.jcp.org/jcr/nt/1.0" >
>
>  <index-rule nodeType="th:hierarchyNode" boost="2.0">
>     <property>jcr:description</property>
>     <property>jcr:author</property>
>     <property>jcr:lastModify</property>
>     <property>jcr:created</property>
>   </index-rule>
>
>   <index-rule nodeType="th:resource" boost="4.0">
>     <property>jcr:description</property>
>     <property>jcr:filename</property>
>     <property>jcr:extension</property>
>     <property>jcr:encoding</property>
>     <property>jcr:mimeType</property>
>     <property>jcr:data</property>
>     <property>jcr:lastModified</property>
>   </index-rule>
>
>   <index-rule nodeType="th:metadata" boost="2.0">
>     <property>jcr:metadataType</property>
>     <property>jcr:metadataValue</property>
>     <property>jcr:metadataLabel</property>
>   </index-rule>
>
>   <index-rule nodeType="th:fileDocument" boost="2.0">
>     <property>jcr:docType</property>
>     <property>jcr:docTypeDesc</property>
>   </index-rule>
>
>   <index-rule nodeType="th:plainDocument" boost="2.0">
>   </index-rule>
>
> </configuration>
>
> as it can be seen the plainDocument is not configured to be indexed , but when i run
a search i can find it and i even looked at the index on filesystem and i found mark of this
node beenig indexed
>
> i hope you can help me.
> lots of 10x,
> ana r.
>

Mime
View raw message