jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Schreiber <anch...@day.com>
Subject Re: Security Question Jackrabbit 1.6
Date Wed, 16 Sep 2009 07:44:57 GMT
hi


> I find now time to migrate our 1.4 Environment to 1.6 :-) and there is one thing i don't
know exactly.
> I thought we are backward compatible to older relaeses but the AccessManager Interface
introdces
> new Methods that i have now to implement.

i wouldn't call extending an interface a backward compatibility issue.

> The older methods are deprecated but thy will be still called from internal code. 
> The new one will also be called,

most calls calls to the old, deprecated methods were replaced within
jackrabit-core. since it is within other people's code i didn't want
to introduce problems and left a couple of calls untouched, where i 
somehow felt uneasy to change to it (maybe over-careful).

> and for me it looks a little bit specification mixed. 

it doesn't for me. we decided at day that we want to change
the ac evaluation from id-based to path-based.

> Maybe Angela gives me a hint to the best way i have to go ..

what kind of hints do you exactly expect?

regards
angela

Mime
View raw message