jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Bocanegra (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-2206) Replace NodeReferencesId with NodeId
Date Sat, 11 Jul 2009 21:53:15 GMT

    [ https://issues.apache.org/jira/browse/JCR-2206?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12730019#action_12730019
] 

Tobias Bocanegra commented on JCR-2206:
---------------------------------------

in general +1

but i would keep the method names similar to avoid confusion:

  NodeReferences loadReferencesTo(NodeId id)
  boolean existReferencesTo(NodeId targetId)



> Replace NodeReferencesId with NodeId
> ------------------------------------
>
>                 Key: JCR-2206
>                 URL: https://issues.apache.org/jira/browse/JCR-2206
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>          Components: jackrabbit-core
>            Reporter: Jukka Zitting
>            Assignee: Jukka Zitting
>            Priority: Minor
>         Attachments: NodeReferencesId.patch
>
>
> The NodeReferencesId class simply wraps a NodeId and forwards all essential method calls
to it.
> The main (only?) benefit of having NodeReferencesId as a separate class is the ability
to distinguish between the overloaded exists() and load() method signatures on PersistenceManager.
The downside is the need to instantiate all the NodeReferencesId wrapper objects whenever
accessing the references to a node.
> I propose to rename the overloaded methods to hasReferencesTo(NodeId) and getReferencesTo(NodeId)
and to replace the NodeReferencesId with just the target NodeId wherever used.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message