Yeah, come on guys. Does this even *remotely* compare to hitting a disk or a JDBC connection?
My preference would be to just use the regular java syntax. Having static methods can be handy for some of the casting type situations instead of calling something like someClass.cast(foo), but otherwise it just gets in the way.
Keep in mind that when you type "new ArrayList<String>()" in any decent IDE it'll finish the other side for you. Or if you type "List<String> myList = " it'll again present the other side to you. Having to do New.arrayList() just makes it more difficult.
That and I think New.foo() is less readable since it breaks the standard java syntax. It just looks weird.