jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martijn Hendriks <marti...@gx.nl>
Subject Lucene 2.4.1 and jackrabbit-core-1.5.4
Date Fri, 08 May 2009 06:00:37 GMT
Hi all,

I've been looking at merging the patch for issue JCR-1855 to jackrabbit-core-1.5.4 to get
rid of a lucene memory leak, but for me that's not straightforward. I noticed, however, that
the core compiles and builds (including all tests) if you only change the lucene dependency
to 2.4.1. The patch of JCR-1855 contains a lot of code that replaces depercated method calls.
Is that all that happens? Is it safe to only upgrade the version number and let the jackrabbit
query code as it is?

Best regards,

Martijn


Mime
View raw message