jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manfred Baedke <manfred.bae...@greenbytes.de>
Subject Re: Generics generator class
Date Tue, 05 May 2009 10:08:16 GMT
Hi,

now I can't resist to throw in my 2ct. Maybe this could grow into a nice 
flame war? :)
But seriously: since when is less verbose automatically easier to read? 
Readability and verbosity are different things and (IMHO) not very 
closely connected.
In this very case the verbose version is just what every developer is 
used to see a few times everyday. Takes about a millisecond to see what 
it's all about.

Regards,
Manfred

Thomas Müller wrote:
> Hi,
>
> New.hashMap() is unusual. But: confusing? Since when is verbose is
> easier to read?
>
>   
>> you know what you get
>>     
>
> How could you possibly _not_ know what you get with New.arrayList()?
>
>   
>> it creates a new dependency to another package.
>>     
>
> The dependency to the commons library is already there. So you want to
> avoid an _import_ statement?
>
> Regards,
> Thomas
>   

-- 
Manfred Baedke

<green/>bytes GmbH
Hafenweg 16
D-48155 Münster
Germany
Amtsgericht Münster: HRB5782 


Mime
View raw message