jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jukka Zitting <jukka.zitt...@gmail.com>
Subject Re: Build failed in Hudson: Jackrabbit-trunk-java14 #158
Date Tue, 07 Apr 2009 16:00:45 GMT
Hi,

On Tue, Apr 7, 2009 at 5:49 PM, Apache Hudson Server
<hudson@hudson.zones.apache.org> wrote:
> [INFO] Compilation failure
> http://hudson.zones.apache.org/hudson/job/Jackrabbit-trunk-java14/ws/trunk/jackrabbit-text-extractors/src/main/java/org/apache/jackrabbit/extractor/MsPowerPointTextExtractor.java
:[19,-1] cannot access org.apache.poi.poifs.eventfilesystem.POIFSReader
> bad class file: /home/hudson/.m2/repository/org/apache/poi/poi/3.5-beta5/poi-3.5-beta5.jar(org/apache/poi/poifs/eventfilesystem/POIFSReader.class)
> class file has wrong version 49.0, should be 48.0

The new POI version needed for OOXML support only works in Java 5 and higher.

I think the OOXML support is important enough to keep even with this
drawback. I'll work around the issue so that the trunk still builds on
Java 1.4, but text extraction of Microsoft Office files will be
needing at least Java 5 in Jackrabbit 1.6.

People who still run Jackrabbit on Java 1.4 can keep Office text
extraction support in Jackrabbit 1.6.0 by keeping the
jackrabbit-text-extractors dependency at version 1.5.0.

BR,

Jukka Zitting

Mime
View raw message