jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Brooking (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-2069) Upgrade to cglib 2.2 (asm-3.1)
Date Sun, 12 Apr 2009 03:26:14 GMT

    [ https://issues.apache.org/jira/browse/JCR-2069?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12698162#action_12698162
] 

Charles Brooking commented on JCR-2069:
---------------------------------------

Try using cglib-nodep instead. It has no external dependency on asm-1.5.3.

  <dependency>
    <groupId>org.apache.jackrabbit</groupId>
    <artifactId>jackrabbit-ocm</artifactId>
    <version>1.5.x</version>
    <exclusions>
      <exclusion>
        <groupId>cglib</groupId>
        <artifactId>cglib</artifactId>
      </exclusion>
    </exclusions>
  </dependency>
  <dependency>
    <groupId>cglib</groupId>
    <artifactId>cglib-nodep</artifactId>
    <version>2.1_3</version>
  </dependency>


> Upgrade to cglib 2.2 (asm-3.1)
> ------------------------------
>
>                 Key: JCR-2069
>                 URL: https://issues.apache.org/jira/browse/JCR-2069
>             Project: Jackrabbit Content Repository
>          Issue Type: Improvement
>          Components: jackrabbit-ocm
>    Affects Versions: 1.5.3, 1.5.4
>            Reporter: Mark Berner
>             Fix For: 1.5.5
>
>
> Are you planning upgrade to cglib 2.2? Currently you use cglib 2.1_3 which depends from
asm-1.5.3
> I have serious problem using together Jackrabbit-ocm and Groovy.
> Groovy dependds from asm 2.2.3 which incompatible with 1.5.3
> cglib 2.2 dependes from newer asm-3.1

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message