jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Re: Jackrabbit 1.5.1 release plan
Date Thu, 08 Jan 2009 19:04:18 GMT
Hi,

Jukka Zitting schrieb:
> Hi,
> 
> Here's a tricky question: Now that we have a fix to
> jackrabbit-jcr-commons that's scheduled for 1.5.1 (JCR-1926), should
> all the components in the 1.5 branch that depend on jcr-commons also
> be updated?
> 
> For example, jackrabbit-classloader 1.5.0 depends on
> jackrabbit-jcr-commons 1.5.0. Should we update the classloader
> component in Jackrabbit 1.5.1 to depend on jcr-commons 1.5.1, or
> should it remain at version 1.5.0 with the old dependency. Note that
> AFAIK the classloader component does not even use the method fixed in
> JCR-1926.
> 
> I'm inclined to upgrade all the dependent components so that the 1.5.1
> build will not end up referring to two different versions of the same
> component.

No, I would neither upgrade nor release any dependent component. This
would be very confusing and not worth the effort.

Regards
Felix

Mime
View raw message