jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nicholas_dipiazza <nicho...@xerceo.com>
Subject Jackrabbit and Lucene 2.3.2 - AlreadyClosedException
Date Fri, 10 Oct 2008 02:08:38 GMT

So to fix the issue of Jackrabbit 1.4 not working with Lucene 2.3.x, I read
the jira ticket https://issues.apache.org/jira/browse/JCR-1363 - it reports
Lucene 2.3.x with proper patch will work on a fresh Jackrabbit 1.5 from the
repository.

I verified the patch files are applied, and have rebuilt the jackrabbit-core
jar.

The repository fires up with no problem... seems to be no compatibility
issues with the Jackrabbit 1.4 config files I had sitting there.

I can execute one search just fine, but after a second I get:

org.apache.lucene.store.AlreadyClosedException: this IndexReader is closed

Which was the same thing I got from Jackrabbit 1.4. Any ideas? Thanks!

-- 
View this message in context: http://www.nabble.com/Jackrabbit-and-Lucene-2.3.2---AlreadyClosedException-tp19910648p19910648.html
Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.


Mime
View raw message