jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Klimetschek" <aklim...@day.com>
Subject Re: Backwards compatibility of configuration files (Was: [jira] Commented: (JCR-1462) repository.xml: throw an exception on error)
Date Wed, 24 Sep 2008 15:41:19 GMT
On Wed, Sep 24, 2008 at 2:25 PM, Jukka Zitting <jukka.zitting@gmail.com> wrote:
> The question is, should the 1.5 upgrade changes in configuration files
> or not? I would rather opt for a smoother upgrade with more backwards
> compatibility, but I acknowledge that there are good reasons why we
> might want people to update their configurations. WDYT?

+1 for being backwards compatible in a minor 1.x release

In the SecurityManager case I would let the parser allow the old
config, use defaults for the new required component, and log a big
warning on the console that this old config is deprecated. We can
really remove it with Jackrabbit 2.0.

Regards,
Alex

-- 
Alexander Klimetschek
alexander.klimetschek@day.com

Mime
View raw message