jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: Backwards compatibility of configuration files (Was: [jira] Commented: (JCR-1462) repository.xml: throw an exception on error)
Date Wed, 24 Sep 2008 19:37:42 GMT
Hi,

On Wed, Sep 24, 2008 at 8:52 PM, Thomas Müller <thomas.mueller@day.com> wrote:
> In that case the SecurityManager setting should be truly optional: no
> warning should be logged if it is missing.

Why is that?

We can (and should) deprecate old configurations like ones with no
SecurityManager or no DOCTYPE, and logging warnings about deprecated
features is IMHO perfectly fine, even preferable as an aid to make a
future 2.x upgrade (where we probably will drop deprecated stuff) less
painful. But IMHO such deprecated stuff should still continue to work
across minor version upgrades.

BR,

Jukka Zitting

Mime
View raw message