jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guido Jäkel (JIRA) <j...@apache.org>
Subject [jira] Commented: (JCR-1305) JNDI data sources with BundleDbPersistenceManager: UnsupportedOperationException
Date Tue, 09 Sep 2008 07:57:44 GMT

    [ https://issues.apache.org/jira/browse/JCR-1305?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12629415#action_12629415
] 

Guido Jäkel commented on JCR-1305:
----------------------------------

> Could you check that there is no old jackrabbit-core in your classpath?

Gotcha, thanks for analysis. But the mistake is up to the jackrabit team:

Yes indeed, there is a wrong version in the path. But i forget to mention, that i'm using
the jackrabbit-webapp.war because we're currently use RMI communication.

I just take a closer look onto the contents of this war archive. Regardless what version of
the other jackrabbit archives i will offer, this will have no effect -- because this is a
"stand alone" war and have included it's own copy of the libraries inside /WEB-INF/lib/.

And (from my users point of view) *you* forgot to update it and should provide a updated jackrabbit-webapp-1.4.5.war
including the latest version of  (all of) the used libs:

---------------------------------

# unzip -l jackrabbit-webapp-1.4.war  "*/jackrabbit*.jar"                
Archive:  jackrabbit-webapp-1.4.war
  Length     Date   Time    Name
 --------    ----   ----    ----
  1749859  01-11-08 14:41   WEB-INF/lib/jackrabbit-core-1.4.jar
     9734  01-11-08 14:39   WEB-INF/lib/jackrabbit-api-1.4.jar
   164719  01-11-08 14:39   WEB-INF/lib/jackrabbit-jcr-commons-1.4.jar
   112033  01-11-08 14:39   WEB-INF/lib/jackrabbit-spi-commons-1.4.jar
    23095  01-11-08 14:39   WEB-INF/lib/jackrabbit-spi-1.4.jar
    33494  01-11-08 14:40   WEB-INF/lib/jackrabbit-text-extractors-1.4.jar
   259610  01-11-08 14:43   WEB-INF/lib/jackrabbit-jcr-server-1.4.jar
   290856  01-11-08 14:43   WEB-INF/lib/jackrabbit-webdav-1.4.jar
    31311  01-11-08 14:43   WEB-INF/lib/jackrabbit-jcr-servlet-1.4.jar
   217829  01-11-08 14:43   WEB-INF/lib/jackrabbit-jcr-rmi-1.4.jar
 --------                   -------
  2892540                   10 files

-------------------------------

I've created an updated war by myself and it seems to work: At least, now it's starting up
with the JNDI configuration...


Thank you for quick help!

Guido

> JNDI data sources with BundleDbPersistenceManager: UnsupportedOperationException
> --------------------------------------------------------------------------------
>
>                 Key: JCR-1305
>                 URL: https://issues.apache.org/jira/browse/JCR-1305
>             Project: Jackrabbit
>          Issue Type: Bug
>          Components: jackrabbit-core
>    Affects Versions: 1.4
>            Reporter: Thomas Mueller
>            Assignee: Thomas Mueller
>            Priority: Minor
>             Fix For: 1.3.4, core 1.4.1
>
>
> When using the org.apache.tomcat.dbcp.dbcp.BasicDataSourceFactory, the BundleDbPersistenceManager
can not open a database connection via JNDI because the method DataSource.getConnection(user,
password) is not supported. Instead, DataSource.getConnection() must be used for this to work.
> ConnectionFactory.getConnection should be changed to call this method if user name and
password are empty.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message