jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject The concurrent library (Re: Locking issues with XAItemStateManager - help appreciated)
Date Wed, 25 Jun 2008 10:44:45 GMT
Hi,

[Moving the thread to dev@]

On Wed, Jun 25, 2008 at 1:31 PM, sbarriba <sbarriba@yahoo.co.uk> wrote:
> ...and as an aside I note from
> http://g.oswego.edu/dl/classes/EDU/oswego/cs/dl/util/concurrent/intro.html
> That concurrent 1.3.4 is now in maintenance mode.
> Is there a plan to move to java.util.concurrent within the JDK?

Jackrabbit is currently (mostly) based on Java 1.4, that doesn't yet
have the java.util.concurrent library.

There's the backport-util-concurrent library [1] that we could
(should?) migrate to before upgrading to Java 5.

However, last time I checked the required Jackrabbit modifications are
not trivial (some of the classes and semantics in concurrent 1.3.4 are
different from java.util.concurrent) so unless someone wants to
scratch that itch and provide a good patch for this I'm inclined to
stick with the what we have now.

[1] http://backport-jsr166.sourceforge.net/

BR,

Jukka Zitting

Mime
View raw message