jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Reschke <julian.resc...@gmx.de>
Subject Re: Java 5 in Jackrabbit 2.0?
Date Wed, 25 Jun 2008 12:46:07 GMT
Stefan Guggisberg wrote:
> jsr 283 currently requires java 1.4 or higher. if jackrabbit 2.0 (i.e.

Yes.

> the JCR 2.0 RI) would require java 5 we have a compatibility
> issue.

Really? Why. Or does the RI need to prove that it can be implemented in 
Jave 1.4?

> i'd be ok with moving to java 5 if we get agreement in the jcr 283 eg
> to raise the system requirements as well.

I always wanted that, but I recall people were against it.

Now that JCR 2.0 does not *use* any Jave 5 features I would argue for 
deferring it to a future spec.

BR, Julian

Mime
View raw message