jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] Created: (JCR-1658) Executing query throws UnsupportedRepositoryOperationException(LEVEL_2_SUPPORTED) for a level 1 only implementation
Date Thu, 19 Jun 2008 12:01:45 GMT
Executing query throws UnsupportedRepositoryOperationException(LEVEL_2_SUPPORTED) for a level
1 only implementation 
--------------------------------------------------------------------------------------------------------------------

                 Key: JCR-1658
                 URL: https://issues.apache.org/jira/browse/JCR-1658
             Project: Jackrabbit
          Issue Type: Bug
          Components: jackrabbit-jcr2spi
            Reporter: Michael Dürig


Executing a query  throws UnsupportedRepositoryOperationException(LEVEL_2_SUPPORTED) it the
spi implementation is not level 2. This is because org.apache.jackrabbit.jcr2spi.query.execute()
calls session.getValueFactory() which - by contract - throws if level 2 is not supported.
A quick fix would be to call getJcrValueFactory() (available from the ManagerProvider interface
implemented by SessionImpl) instead of getValueFactory(). However, I think a better fix might
be to pass the ManagerProvider to the QueryImpl constructor instead of the session, all the
managers and providers separately.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message