jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Haderka (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-1223) Ocassionally NPE on node checkin
Date Tue, 27 May 2008 12:04:40 GMT

    [ https://issues.apache.org/jira/browse/JCR-1223?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12600092#action_12600092
] 

Jan Haderka commented on JCR-1223:
----------------------------------

Haven't tried with 1.4.4 yet. But will try when I get a bit of time, but tried to access and
modify this node with another app using JR 1.3.3 and that worked fine, tho I'm unable to say
at this point whether it was due different version of JR or different app workflow.

I'm afraid the workflow to replicate the problem is bit more complex then I have described
at the begining. What the system does under the hood is: 
- on first try, clone the given node from one workspace to another, then add mix:versionable
to cloned node and create a version
- next time when I want to version, cloned node in second workspace is just updated with the
latest values of properties and versioned again. Sometimes instead of updating the node system
might choose to delete the node and clone it again.

When I looked at the node (via app using JR 1.3.3) I could see that there were only 6 versions
stored for versioned node and since I did versioning 8 times, some of the versions have been
recycled (which is what i wanted so no problem here).

I will try to extract standalone test case, but can't promise since it is buried quite deep
in the app to simply extract it from there and i'm quite busy at the moment.

Also, note that I managed to avoid the problem from occuring in a first place, by forcing
the system to delete all versions before deleting the node (in the case when node in second
workspace is deleted instead of updated).

> Ocassionally NPE on node checkin
> --------------------------------
>
>                 Key: JCR-1223
>                 URL: https://issues.apache.org/jira/browse/JCR-1223
>             Project: Jackrabbit
>          Issue Type: Bug
>          Components: jackrabbit-core, versioning
>    Affects Versions: 1.3.1
>            Reporter: Christoph Kiehl
>         Attachments: JR-stacktrace.txt
>
>
> I find the following Exception in our log files from time to time. I don't know how to
replicate it and I couldn't find a ticket in Jira nor seemed the recent changes on the participating
classes in trunk handling this error:
> java.lang.NullPointerException
>         at org.apache.jackrabbit.core.version.InternalVersionImpl.storeXCessors(InternalVersionImpl.java:225)
>         at org.apache.jackrabbit.core.version.InternalVersionImpl.internalAddSuccessor(InternalVersionImpl.java:281)
>         at org.apache.jackrabbit.core.version.InternalVersionImpl.internalAttach(InternalVersionImpl.java:265)
>         at org.apache.jackrabbit.core.version.InternalVersionHistoryImpl.checkin(InternalVersionHistoryImpl.java:444)
>         at org.apache.jackrabbit.core.version.AbstractVersionManager.checkin(AbstractVersionManager.java:375)
>         at org.apache.jackrabbit.core.version.XAVersionManager.checkin(XAVersionManager.java:368)
>         at org.apache.jackrabbit.core.version.XAVersionManager.checkin(XAVersionManager.java:157)
>         at org.apache.jackrabbit.core.NodeImpl.checkin(NodeImpl.java:2933) 
> [...]

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message