jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Marcel Reutegger (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (JCR-1568) Failed to upgrade tm-extractors
Date Wed, 07 May 2008 10:33:55 GMT

     [ https://issues.apache.org/jira/browse/JCR-1568?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Marcel Reutegger resolved JCR-1568.
-----------------------------------

    Resolution: Won't Fix

tm-extractors will not be used anymore in 1.5 and has already been removed from the pom.xml
in trunk.

According to our release policy we don't change dependencies in a branch, therefore closing
this won't fix.

> Failed to upgrade tm-extractors
> -------------------------------
>
>                 Key: JCR-1568
>                 URL: https://issues.apache.org/jira/browse/JCR-1568
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: jackrabbit-text-extractors
>    Affects Versions: core 1.4.2
>         Environment: JDK 1.6; Tomcat 6; Windows 2003
>            Reporter: Julio Castillo
>
> I tried to upgrade the version of tm-extractros from 0.4 to the new release 1.0, but
got an exception. There are appears to be some obscure dependency.
> 01.05.2008 13:05:50 *WARN * JackrabbitTextExtractor: Extractor dependency not found:
org.apache.jackrabbit.extractor.MsWordTextE
> xtractor (JackrabbitTextExtractor.java, line 128)
> java.lang.NoClassDefFoundError
>         at org.apache.jackrabbit.extractor.MsWordTextExtractor.class$(MsWordTextExtractor.java:37)
>         at org.apache.jackrabbit.extractor.MsWordTextExtractor.<clinit>(MsWordTextExtractor.java:43)
>         at java.lang.Class.forName0(Native Method)
>         at java.lang.Class.forName(Class.java:169)
>         at org.apache.jackrabbit.core.query.lucene.JackrabbitTextExtractor.<init>(JackrabbitTextExtractor.java:113)
>         at org.apache.jackrabbit.core.query.lucene.SearchIndex.createTextExtractor(SearchIndex.java:881)
>         at org.apache.jackrabbit.core.query.lucene.SearchIndex.doInit(SearchIndex.java:395)
>         at org.apache.jackrabbit.core.query.AbstractQueryHandler.init(AbstractQueryHandler.java:48)
>         at org.apache.jackrabbit.core.SearchManager.initializeQueryHandler(SearchManager.java:573)
>         at org.apache.jackrabbit.core.SearchManager.<init>(SearchManager.java:255)
>         at org.apache.jackrabbit.core.RepositoryImpl.getSystemSearchManager(RepositoryImpl.java:625)
> ....
> Please note the different classes bundled in the 0.4 vs the 1.0 jar files.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message