jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "angela (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-1550) Remove ItemInfo.getName() since it is redundant
Date Thu, 24 Apr 2008 09:41:22 GMT

    [ https://issues.apache.org/jira/browse/JCR-1550?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12591964#action_12591964

angela commented on JCR-1550:

you are right... since it seems not to be used currently with jcr2spi nor with any of the
implementations i am in favor of that change.

concerns/objections by anybody?

> Remove ItemInfo.getName() since it is redundant
> -----------------------------------------------
>                 Key: JCR-1550
>                 URL: https://issues.apache.org/jira/browse/JCR-1550
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: jackrabbit-spi
>    Affects Versions: 1.4
>            Reporter: Michael Dürig
>            Priority: Minor
> I propose to remove the method getName() from org.apache.jackrabbit.spi.ItemInfo since
it is redundant. The name is always the last element of the path which is available via the
getPath() method.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message