jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "angela (JIRA)" <j...@apache.org>
Subject [jira] Updated: (JCR-1550) Remove ItemInfo.getName() since it is redundant
Date Thu, 24 Apr 2008 10:09:22 GMT

     [ https://issues.apache.org/jira/browse/JCR-1550?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

angela updated JCR-1550:
------------------------

    Attachment: JCR-1550.diff

proposed patch for the trunk

> Remove ItemInfo.getName() since it is redundant
> -----------------------------------------------
>
>                 Key: JCR-1550
>                 URL: https://issues.apache.org/jira/browse/JCR-1550
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: jackrabbit-spi
>    Affects Versions: 1.4
>            Reporter: Michael Dürig
>            Priority: Minor
>         Attachments: JCR-1550.diff
>
>
> I propose to remove the method getName() from org.apache.jackrabbit.spi.ItemInfo since
it is redundant. The name is always the last element of the path which is available via the
getPath() method.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message