jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Dürig (JIRA) <j...@apache.org>
Subject [jira] Created: (JCR-1402) Path.getAncestor and Path.getAncestorCount are misnomers
Date Wed, 20 Feb 2008 13:55:43 GMT
Path.getAncestor and Path.getAncestorCount are misnomers

                 Key: JCR-1402
                 URL: https://issues.apache.org/jira/browse/JCR-1402
             Project: Jackrabbit
          Issue Type: Improvement
          Components: jackrabbit-spi, jackrabbit-spi-commons
    Affects Versions: 1.4
            Reporter: Michael Dürig
            Priority: Minor

Although the method names refer to ancestors they operate on sub-paths. Consider:

PathFactory pf = PathFactoryImpl.getInstance();
Path.Element p = pf.getParentElement();

Path path = pf.create(new Path.Element[]{p, p});
Path ancestor = path.getAncestor(1);

assertFalse(ancestor.isAncestorOf(path) )  

This is not what one would expect from looking an the method signatures. 
I suggest to rename getAncestor to getSubPath, clarify the javadoc, and deprecate getAncestorCount.

A patch follows.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message