jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: jackrabbit-core 1.4.1 release plan
Date Fri, 01 Feb 2008 06:34:14 GMT
Hi,

On Jan 30, 2008 4:02 PM, Ard Schrijvers <a.schrijvers@hippo.nl> wrote:
> Not sure if it is an issue we already want to address, but Jackrabbit
> 1.4 does not work with the just released lucene 2.2.3. Lucene 2.2.3 has
> quite some changing regarding refCounting and this does not work well
> ATM with the jr 1.4 refCounting / caching of readers. It is not yet a
> jira issue, but as i already said, I am not sure wether we want to
> address it in the first place...

It probably makes sense to file it at least as a known issue in Jira.
I'd be happy to include a reasonable fix in 1.4.1, but IMHO it's no
problem if such a fix is not available as our stated dependency is to
Lucene 2.2.0.

Just curious, is Lucene breaking backwards compatibility or is this
just because we're integrating with Lucene much more deeply than
people normally do?

BR,

Jukka Zitting

Mime
View raw message