jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Reschke <julian.resc...@gmx.de>
Subject Re: [jira] Commented: (JCR-1405) SPI: Introduce NodeInfo.getChildInfos()
Date Mon, 25 Feb 2008 16:40:13 GMT
Michael Dürig wrote:
>>
>> ...we may want to rename it to getNodeInfos() then :-)
> 
> Actually I'd prefer something along the line of getChildNodeInfos() to 
> be more explicit and to clearly differentiate it from getNodeInfo().

Now we're talking :-)

Let's change

     public Iterator<ChildInfo> getChildInfos(SessionInfo sessionInfo, 
NodeId parentId) throws ItemNotFoundException, RepositoryException;

to

     public Iterator<NodeInfo> getChildNodeInfos(SessionInfo 
sessionInfo, NodeId parentId) throws ItemNotFoundException, 
RepositoryException;

(using generics notation for clarity)

Also, let's change

     public PropertyInfo getPropertyInfo(SessionInfo sessionInfo, 
PropertyId propertyId) throws ItemNotFoundException, RepositoryException;

to

     public Iterator<PropertyInfo> getPropertyInfo(SessionInfo 
sessionInfo, PropertyId[] propertyId) throws ItemNotFoundException, 
RepositoryException;

...so that batch handling applies to properties as well, and many can ve 
read in one call (I would assume that many properties are always fetched 
together, such as those on nt:resource or mix:lockable)

BR, Julian







Mime
View raw message