jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Angela Schreiber <anch...@day.com>
Subject Re: Jackrabbit 1.4 test failure
Date Mon, 07 Jan 2008 14:04:46 GMT
hi thomas

Thomas Mueller wrote:
> Hi,
> 
> On of the tests fails when I build Jackrabbit 1.4 on my machine. I
> have checked out the Jackrabbit 1.4 branch to a new directory, and
> called:
> 
> mvn clean install
> 
> The error is:
> Building Jackrabbit JCR to SPI
>    task-segment: [clean, install]
> ---------------------------------
> ...
> testRevertReorder(org.apache.jackrabbit.jcr2spi.ReorderReferenceableSNSTest)
> junit.framework.AssertionFailedError: Reorder added a child node.
> 	at junit.framework.Assert.fail(Assert.java:47)
> 	at org.apache.jackrabbit.jcr2spi.ReorderTest.testOrder(ReorderTest.java:90)
> 	at org.apache.jackrabbit.jcr2spi.ReorderTest.testRevertReorder(ReorderTest.java:122)
> 
> mvn -version gives me:
> Maven version: 2.0.7
> Java version: 1.4.2_13
> OS name: "windows xp" version: "5.1" arch: "x86"
> 
> Is this expected? 

No. To my knowledge these tests passed when i built the
jackrabbit project before christmas...

> If yes then probably the test should be disabled in
> the 1.4 branch? 

Rather not. I would prefer to find out, what makes them
failing now. Since i'm not yet though all my mail, i don't have
an overview over recent changes... Did anything change in
jcr2spi or in jackrabbit-core that could cause such problems?

angela

Mime
View raw message