jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From KÖLL Claus <C.KO...@TIROL.GV.AT>
Subject rap startup problems
Date Thu, 13 Sep 2007 07:01:59 GMT
hi 

i try to run my first rap project but my server stops immediatelly after start
the log ..

osgi> 13.09.2007 08:57:17 org.mortbay.http.HttpServer doStart
INFO: Version Jetty/5.1.x
13.09.2007 08:57:17 org.mortbay.util.Container start
INFO: Started org.mortbay.jetty.servlet.ServletHandler@1e845c2
13.09.2007 08:57:17 org.mortbay.util.Container start
INFO: Started HttpContext[/,/]
13.09.2007 08:57:17 org.mortbay.http.SocketListener start
INFO: Started SocketListener on 0.0.0.0:9082
13.09.2007 08:57:17 org.mortbay.util.Container start
INFO: Started org.mortbay.http.HttpServer@2bb514
13.09.2007 08:57:17 org.mortbay.util.ThreadedServer$Acceptor run
INFO: Stopping Acceptor ServerSocket[addr=0.0.0.0/0.0.0.0,port=0,localport=9082]
13.09.2007 08:57:17 org.mortbay.http.SocketListener stop
INFO: Stopped SocketListener on 0.0.0.0:9082
13.09.2007 08:57:17 org.mortbay.util.Container stop
INFO: Stopped org.mortbay.jetty.servlet.ServletHandler@1e845c2
13.09.2007 08:57:17 org.mortbay.util.Container stop
INFO: Stopped HttpContext[/,/]
13.09.2007 08:57:17 org.mortbay.util.Container stop
INFO: Stopped org.mortbay.http.HttpServer@2bb514

if i start with -consolelog i get this exception ..

java.lang.RuntimeException: No application id has been found.
	at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:229)
	at org.eclipse.equinox.internal.app.EclipseAppContainer.start(EclipseAppContainer.java:92)
	at org.eclipse.equinox.internal.app.Activator.addingService(Activator.java:129)
	at org.osgi.util.tracker.ServiceTracker$Tracked.trackAdding(ServiceTracker.java:1064)
	at org.osgi.util.tracker.ServiceTracker$Tracked.track(ServiceTracker.java:1042)
	at org.osgi.util.tracker.ServiceTracker$Tracked.serviceChanged(ServiceTracker.java:967)
	at org.eclipse.osgi.framework.internal.core.FilteredServiceListener.serviceChanged(FilteredServiceListener.java:94)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.dispatchEvent(BundleContextImpl.java:1224)
	at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
	at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:141)
	at org.eclipse.osgi.framework.internal.core.Framework.publishServiceEventPrivileged(Framework.java:1603)
	at org.eclipse.osgi.framework.internal.core.Framework.publishServiceEvent(Framework.java:1578)
	at org.eclipse.osgi.framework.internal.core.ServiceRegistrationImpl.<init>(ServiceRegistrationImpl.java:103)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.createServiceRegistration(BundleContextImpl.java:657)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.registerService(BundleContextImpl.java:609)
	at org.eclipse.osgi.framework.internal.core.BundleContextImpl.registerService(BundleContextImpl.java:675)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:359)
	at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:176)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
	at java.lang.reflect.Method.invoke(Unknown Source)
	at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:504)
	at org.eclipse.equinox.launcher.Main.basicRun(Main.java:443)
	at org.eclipse.equinox.launcher.Main.run(Main.java:1169)
	at org.eclipse.equinox.launcher.Main.main(Main.java:1144)

after debuging in the class Activator i find that the ServiceReference 
is instanceof ApplicationLauncher. so he tries to start a EclipseAppContainer 
what do i make wrong ?

thanks
claus

Mime
View raw message