jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom Duffey (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-1118) Upgrade contrib/bdb-persistence to work w/Jackrabbit 1.3
Date Wed, 12 Sep 2007 17:58:32 GMT

    [ https://issues.apache.org/jira/browse/JCR-1118?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12526870
] 

Tom Duffey commented on JCR-1118:
---------------------------------

Patches should be applied to each file and then the Java files must be moved into a new package:
org.apache.jackrabbit.core.persistence.bdb.  Once this is done the old files should be removed.

project.xml needs patching to change to Jackrabbit 1.3.1 and add a new dependency because
Jackrabbit is now split up differently than it was in 1.1.  The Berkeley DB version was also
updated to the latest available for download.

Once applied bdb-persistence is no longer compatible with Jackrabbit 1.1 or older.  It *might*
be compatible with versions between 1.1 and 1.3.1 but I have only tested with 1.3.1.

> Upgrade contrib/bdb-persistence to work w/Jackrabbit 1.3
> --------------------------------------------------------
>
>                 Key: JCR-1118
>                 URL: https://issues.apache.org/jira/browse/JCR-1118
>             Project: Jackrabbit
>          Issue Type: Task
>          Components: contrib PMs
>    Affects Versions: 1.3.1
>            Reporter: Tom Duffey
>         Attachments: BerkeleyDBPersistenceManager.java.patch, NodeReferencesTupleBinding.java.patch,
NodeStateTupleBinding.java.patch, project.xml.patch, PropertyStateTupleBinding.java.patch
>
>
> The bdb-persistence PM in contrib should be upgraded to work w/Jackrabbit 1.3.1

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message