jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Felix Meschberger <fmesc...@gmail.com>
Subject Re: [OCM] Reorganize the contrib
Date Tue, 11 Sep 2007 07:05:15 GMT
Hi,

Am Dienstag, den 11.09.2007, 09:00 +0200 schrieb Christophe Lombart:
> Concerning the annotation support, we have to use java 1.5 but maybe some
> jackrabbit/ocm users are still in java 1.4.
> For Sling, Felix is using another framework (Kxml if I remember). I'm not
> sure that it is interesting to group togehter all thoses dependencies in the
> core.

The reason I chose KXml is that it is much more lightweight than
Digester and has no additional dependencies. No that Sling is in the
Incubator and requires Java 5 anyway, we (the Sling project) might want
to consider moving away from the XML-based configurationn to standard
annotations.

But I agree with Christophe, that as long as Jackrabbit declares to be
running Java 1.4, we should not mix Java 5 stuff into other libraries.

Regards
Felix


Mime
View raw message