jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas Mueller" <thomas.tom.muel...@gmail.com>
Subject Re: JCR 2.0 extensions
Date Wed, 08 Aug 2007 12:54:10 GMT
Hi,

org.apache.jackrabbit.jsr283 is a good idea. In a new component, or in
jackrabbit-api.

> But since jsr283 should be mainly backwards compatible

It's not. Some methods now return something that didn't before.

> In case we do ran up with compatibility issues,
> I think we have a good case to request a change in JSR 283.

Maybe making the JSR 283 API backwards compatible is the best solution.

If this is not done, one solution is to use wrapper classes for both
JCR 1.0 and JCR 2.0. Another solution: 'switch' the code to one or the
other API by automatically 'remarking out' (filtering) the 'wrong'
method.

Thomas

Mime
View raw message