jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (JCR-1006) StackOverflowError if too many versions of a node are created
Date Fri, 20 Jul 2007 22:15:06 GMT

     [ https://issues.apache.org/jira/browse/JCR-1006?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jukka Zitting resolved JCR-1006.
--------------------------------

       Resolution: Fixed
    Fix Version/s: 1.3.1

Patch committed in revision 558167 and merged to the 1.3 branch in revision 558173. Thanks!

> StackOverflowError if too many versions of a node are created
> -------------------------------------------------------------
>
>                 Key: JCR-1006
>                 URL: https://issues.apache.org/jira/browse/JCR-1006
>             Project: Jackrabbit
>          Issue Type: Bug
>          Components: versioning
>    Affects Versions: 1.3
>            Reporter: Christoph Kiehl
>            Assignee: Jukka Zitting
>             Fix For: 1.3.1
>
>         Attachments: VersionIteratorImpl.patch
>
>
> In org.apache.jackrabbit.core.version.VersionIteratorImpl addVersion() is called recursively
which can cause StackOverflowErrors if there are too many versions.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message