jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edgar Poce" <edgarp...@gmail.com>
Subject Re: Newbie Maven question
Date Tue, 05 Jun 2007 18:36:08 GMT
On 6/5/07, Julian Reschke <julian.reschke@gmx.de> wrote:
> Christoph Kiehl wrote:
> > Julian Reschke wrote:
> >
> >> For instance, contrib/jcr-navigator wants jackrabbit-core version
> >> 1.1-SNAPSHOT, which I can't (?) build from trunk, nor is available
> >> from repo1.maven.org.
> >
> > repo1.maven.org doesn't host SNAPSHOT dependencies. AFAIK Jackrabbit
> > SNAPSHOT dependencies are hosted by this repository:
> >
> > http://people.apache.org/repo/m2-snapshot-repository/
> >
> > But in this repository there is no 1.1-SNAPSHOT version. Since the
> > reason for using a SNAPSHOT version is most likely to become aware of
> > integration problems early it makes almost no sense to use 1.1-SNAPSHOT
> > here. I would use either a stable version like 1.1, 1.2, 1.3 or use the
> > current snapshot which is 1.4-SNAPSHOT.
> > ...
>
> Understood. So these contrib projects probably just need to be updated
> to require 1.4-SNAPSHOT, right?
>

You should probably change it to 1.1, jcr-navigator project uses some
classes from jcr-server that changed in the next versions.

> Best regards, Julian
>

Mime
View raw message