jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Guggisberg (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-930) [OCM] rename o.a.j.ocm.persistence.PersistenceManager to avoid confusion with core component
Date Wed, 06 Jun 2007 08:13:26 GMT

    [ https://issues.apache.org/jira/browse/JCR-930?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12501844
] 

Stefan Guggisberg commented on JCR-930:
---------------------------------------

ObjectManager is perhaps too generic, how about e.g. ObjectStore? 

> [OCM] rename o.a.j.ocm.persistence.PersistenceManager to avoid confusion with core component
> --------------------------------------------------------------------------------------------
>
>                 Key: JCR-930
>                 URL: https://issues.apache.org/jira/browse/JCR-930
>             Project: Jackrabbit
>          Issue Type: Task
>          Components: jcr-mapping
>    Affects Versions: 1.3
>            Reporter: Stefan Guggisberg
>            Priority: Minor
>             Fix For: 1.4
>
>
> PersistenceManager is a well known and established interface in jackrabbit's architecture.
the same-named class in the
> jcr-mapping contrib project should IMO be renamed in order to avoid confusion in mailing
list threads and jira issues,

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message