jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From qcfireball <qcfireb...@yahoo.com>
Subject Re: jcr-rmi problems
Date Fri, 15 Jun 2007 17:19:02 GMT

I just had a BIG   "A H A A A"  - I forgot about that.  I had a similar
problem with Unix classpaths.  Thank you VERY much for your help.



Christoph Kiehl wrote:
> 
> qcfireball wrote:
> 
>> Tomcat server log shows that the RMI Objects are created in the RMI
>> registry.
>> 
>> I can retrieve an instance of the Repository factory OK via:
>> 
>> ClientRepositoryFactory factory = new ClientRepositoryFactory();
>> final Object o = factory.getRepository(s);
>> 
>> but when I try to "login" to the "default" workspace, I get the following
>> RMI error:
>> 
>> 
>> org.apache.jackrabbit.rmi.client.RemoteRepositoryException: error
>> unmarshalling return; nested exception is: 
>>         java.net.MalformedURLException: no protocol: and: error
>> unmarshalling return; nested exception is: 
>>         java.net.MalformedURLException: no protocol: and
> 
> This is a common error when using RMI. It took me some time to find out 
> what's happening there when it occurred to me the first time. The "and" 
> comes from the folder where your classes are which is probably something 
> beneath "C:\Documents and Settings". Moving your application to a folder 
> without spaces or setting the system property 
> "java.rmi.server.useCodebaseOnly" to true should solve the problem.
> 
> Cheers,
> Christoph
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/jcr-rmi-problems-tf3928960.html#a11144082
Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.


Mime
View raw message