jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eduardo Burgos (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-848) javacc-maven-plugin version in jackrabbit-core pom file
Date Thu, 24 May 2007 14:01:36 GMT

    [ https://issues.apache.org/jira/browse/JCR-848?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12498646
] 

Eduardo Burgos commented on JCR-848:
------------------------------------

Wow, this was more than a month ago, now when I did svn update nothing compiles at all. I'm
using Maven 2.0.6, that time I was using 2.0.4.




[INFO] Compiling 503 source files to /root/src/jackrabbit/trunk/jackrabbit-core/target/classes
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Compilation failure

/root/src/jackrabbit/trunk/jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/sql/ASTIdentifier.java:[21,35]
cannot find symbol
symbol: class SimpleNode
public class ASTIdentifier extends SimpleNode {

/root/src/jackrabbit/trunk/jackrabbit-core/target/generated-src/main/java/org/apache/jackrabbit/core/query/sql/JCRSQLParser.java:[26,53]
cannot find symbol
symbol: class JCRSQLParserTreeConstants
public class JCRSQLParser/*@bgen(jjtree)*/implements JCRSQLParserTreeConstants, JCRSQLParserConstants
{/*@bgen(jjtree)*/


> javacc-maven-plugin version in jackrabbit-core pom file
> -------------------------------------------------------
>
>                 Key: JCR-848
>                 URL: https://issues.apache.org/jira/browse/JCR-848
>             Project: Jackrabbit
>          Issue Type: Bug
>          Components: core
>         Environment: linux desktop, normal pc, java 1.5
>            Reporter: Eduardo Burgos
>            Priority: Minor
>
> Hi, I noticed that the pom.xml file of the jackrabbit-core project needs to specify version
"2.1" for the javacc-maven-plugin because if it takes the 2.2-SNAPSHOT it won't compile. I
put the 2.1 version and it worked fine.
> <plugin>
>         <groupId>org.codehaus.mojo</groupId>
>         <artifactId>javacc-maven-plugin</artifactId>
>         <version>2.1</version>
>         <executions>
> Im working with revision 529712 [April 17, 2007, 15:05 EST]

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message