jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (JCR-925) Incorrect transitive snapshot dependencies
Date Tue, 15 May 2007 20:17:16 GMT

     [ https://issues.apache.org/jira/browse/JCR-925?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jukka Zitting resolved JCR-925.
-------------------------------

    Resolution: Fixed

Fixed in revision 538302.

PS. I didn't mark this as fixed for any future version, as the problem only affects SNAPSHOT
dependencies.

> Incorrect transitive snapshot dependencies
> ------------------------------------------
>
>                 Key: JCR-925
>                 URL: https://issues.apache.org/jira/browse/JCR-925
>             Project: Jackrabbit
>          Issue Type: Bug
>          Components: maven
>            Reporter: Jukka Zitting
>         Assigned To: Jukka Zitting
>            Priority: Minor
>
> Using ${version} in dependency declarations causes troubles since for snapshot dependencies
the version variable apparently gets replaced by the exact timestamp of a deployed snapshot
instead of the "x.y-SNAPSHOT" string. Typically the timestamps of different artifacts are
not the same, causing broken dependencies.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message