jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christoph Kiehl <christ...@sulu3000.de>
Subject Using snapshot builds with maven guide
Date Wed, 18 Apr 2007 09:33:38 GMT
Hi,

I recently tried using the jackrabbit snapshot build from 
http://people.apache.org/repo/m2-snapshot-repository/org/apache/jackrabbit/. One 
problem I discovered is that in the POM for jackrabbit-core for example there 
are no versions for jackrabbit dependencies like jackrabbit-api defined. This 
leads maven to search for an jackrabbit-api artifact with the same version 
number as the jackrabbit-core artifact. This works quite well for release 
versions but not for snapshots since they got different build numbers as well as 
dates all the time. To use these snapshots you have to explicitly specify which 
version of for example jackrabbit-api you want to use. Like this:

<dependency>
   <groupId>org.apache.jackrabbit</groupId>
   <artifactId>jackrabbit-core</artifactId>
   <version>1.3-SNAPSHOT</version>
</dependency>
<dependency>
   <groupId>org.apache.jackrabbit</groupId>
   <artifactId>jackrabbit-api</artifactId>
   <version>1.3-SNAPSHOT</version>
</dependency>
<dependency>
   <groupId>org.apache.jackrabbit</groupId>
   <artifactId>jackrabbit-jcr-commons</artifactId>
   <version>1.3-SNAPSHOT</version>
</dependency>
<dependency>
   <groupId>org.apache.jackrabbit</groupId>
   <artifactId>jackrabbit-text-extractors</artifactId>
   <version>1.3-SNAPSHOT</version>
</dependency>

Note that you have to include an slf4j implementation as well. For log4j is 
looks like this:

<dependency>
	<groupId>org.slf4j</groupId>
	<artifactId>slf4j-log4j12</artifactId>
	<version>1.3.1</version>
</dependency>

I hope to save someone going through the same troubles I went through ;)

Cheers,
Christoph


Mime
View raw message