jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting" <jukka.zitt...@gmail.com>
Subject Re: jackrabbit-core no longer compilable with JDK 1.4
Date Thu, 05 Apr 2007 07:07:13 GMT
Hi,

On 4/4/07, Ate Douma <ate@douma.nu> wrote:
> https://issues.apache.org/jira/browse/JCR-804
>    http://svn.apache.org/viewvc?view=rev&revision=520841
>
> introduced JDK 5.0 language features.
> [...]
> Should I create a JIRA issue for this or is JDK 1.4 compliance no longer
> a requirement for Jackrabbit?

I looked at it some while ago (I got the same Eclipse errors), but
didn't investigate it deeper since at least Sun javac 1.4.2 compiles
the class withough problems. AFAIK such inner class structures should
be supported already in Java 1.4, but I haven't looked up the detailed
requirements from the Java specs.

In any case it's certainly an inconvenience, so filing a bug report or
at least an improvement request would be good.

BR,

Jukka Zitting

Mime
View raw message