jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack Park <jack.p...@sri.com>
Subject Re: Test failure compiling against Lucene 2.1.0
Date Tue, 10 Apr 2007 20:14:04 GMT
Issue self-resolved when compiling from the distribution rather than 
subversion. No problems running against Lucene 2.1.0 after tweaking 
PersistentIndex.

Jack

Jack Park wrote:
> The following trace is occuring both when building directly from svn on 
> Lucene 2.0.0, and after hand-installing jcr-1.0.jar (which failed to 
> download) and Lucene 2.1.0, which isn't in maven yet. It's clear that 
> the compile failure (running unit tests) is not associated with which 
> Lucene is involved.
> 
> * * * * * * * *
> Running org.apache.jackrabbit.test.TestAll
> [Fatal Error] :1:10: Attribute name "is" associated with an element type 
> "this"
> must be followed by the ' = ' character.
> [Fatal Error] :1:10: Attribute name "is" associated with an element type 
> "this"
> must be followed by the ' = ' character.
> [Fatal Error] :-1:-1: Premature end of file.
> [Fatal Error] :-1:-1: Premature end of file.
> * * * * * * * *
> 
> The failure appears to occur in
> SetValueVersionExceptionTest.testNode()
> where the String nodeType3 = getProperty("nodetype3");
> is null.
> Seems like a property named "nodetype3" is not being built. I see no 
> particular nodetype3 in repositoryStubImpl.properties that associates 
> itself with this test.
> 
> If I hand substitute nt:hierarchyNode  or jcr:content (both wild-ass 
> guesses), I see the same failure.
> 
> I'd appreciate any insight here. I instrumented 
> AbstractJCRTest.getProperty() but it's called so many times (apparently 
> successfully) that there's no hint why it failed to return "nodetype3"
> 
> Many thanks in advance.
> Jack


Mime
View raw message