jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ate Douma <...@douma.nu>
Subject jackrabbit-core no longer compilable with JDK 1.4
Date Wed, 04 Apr 2007 17:07:19 GMT
https://issues.apache.org/jira/browse/JCR-804
   http://svn.apache.org/viewvc?view=rev&revision=520841

introduced JDK 5.0 language features.

Error messages when trying to compile with JDK 1.4 (in Eclipse):

   No enclosing instance of type RangeQuery is accessible. Must qualify the allocation with
an enclosing instance of type RangeQuery (e.g. x.new A() where x is 
   an instance of RangeQuery). jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/lucene/RangeQuery.java,
line 189
   No enclosing instance of type WildcardQuery is accessible. Must qualify the allocation
with an enclosing instance of type WildcardQuery (e.g. x.new A() where 
x is an instance of WildcardQuery). jackrabbit-core/src/main/java/org/apache/jackrabbit/core/query/lucene/WildcardQuery.java,
line 163

Should I create a JIRA issue for this or is JDK 1.4 compliance no longer a requirement for
Jackrabbit?

Regards,

Ate

Mime
View raw message