jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Savas Triantafillou" <savvas.triantafil...@gmail.com>
Subject Re: Strange behavior on upgrade from 1.1.1 to 1.2.1
Date Tue, 13 Mar 2007 20:10:43 GMT
HI,

the whole directory... not only indeces...

the funny thing is that there was no error no warning message...

To be more specific the only change that I have made was that I have removed
from cnd file
some namespace declarations that were no longer in use in the custom node
types.

I have tried to remove these namespaces using JCR API but an exception was
thrown saying that
"unregistering namespaces is not supported"

that is why I have deleted namepsaces frmo cnd, deleted all files under
repository directoy
and started Repository in order to get the changes

After that all queries concerning custom nodes behave like repository is
empty
although I can see repository content through JCR eclipse browser

Savvas

On 3/13/07, Marcel Reutegger < marcel.reutegger@gmx.net> wrote:
>
> Savas Triantafillou wrote:
> > Hi,
> >
> > I would like to describe a similar situation and would really need your
> > opinion on this
> >
> > During some development I have once again deleted repository home
> directory
> > without migrating from 1.1 to 1.2.x
> >
> > Once repository started again and index was rebuilt without any
> problems,
> >
> > the same problem with the results of the queries appeared, that is query
> > results did not take into account nodes which
> > were created before rebuilding repository home directory.
> >
> > If a new node was added to the repository, it showed in the queries
> results
> >
> > I have checked JCR browser and all of previous nodes exists, so I have
> > tried
> > the following
> >
> > I have used method getNodeByUUID to get an "old" versionable node,
> checked
> > it out and then checked it in and saved the session.
> >
> > Then I rerun the query it showed up in the results!!!
> >
> > Does anybody have a hint of why this might be happening?
>
> from your description I'd say something went wrong when you re-indexed the
> workspaces.
>
> you say you deleted the repository home directory, this even deletes the
> workspace content, not just the index. or was that a typo in your message?
>
> what are the exact directories you deleted?
>
> regards
>   marcel
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message