jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olivier Dony <olivier.d...@denali.be>
Subject Possible deadlock of jcr-server 1.2.1 (rmi)
Date Tue, 13 Mar 2007 17:19:19 GMT
Hi,

We are using the Repository Server deployment model for one of our  
systems, with 3 different web applications using the same jackrabbit  
server.
Each webapp is running in a separate Tomcat5 server, and jackrabbit  
1.2.1 is running as a jcr server in a 3rd Tomcat server.

Everything has been doing fine for weeks, but yesterday the  
jackrabbit server suddenly stopped responding to all requests,  
seemingly deadlocked.
We had the opportunity to take a threadump of the jackrabbit server  
before performing an emergency restart, which solved the situation.

The thread dump is attached. I tried to make some sense out of it,  
but the read/write locks are hard to follow.
Looks like all RMI-handling thread are waiting to acquire a reader  
lock on the SharedItemStateManager, except one which is waiting for a  
writer lock.
None appear to be ready to release a lock, which is why I suppose  
they were deadlocked.

Is this maybe related to a lock that isn't reentrant but should be?  
Or not?
Can anybody see anything there?

Thanks a lot for having a look!




Mime
View raw message