jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Edgar Poce" <edgarp...@gmail.com>
Subject Re: jcr navigator contrib project
Date Sat, 17 Mar 2007 03:12:26 GMT
Hi James,

On 3/16/07, James Hang <jhang@bea.com> wrote:
> Hi,
> Is anyone using the jcr navigator contrib project?

 I haven't used it a lot but by the time I contributed the project it
worked for me. Unfortunately I'm not using it nor jackrabbit now
because I'm working lots of hours in a project which is not related to
jcr, and I can't maintain it because I hardly see daylight lately. I
hope this situation changes soon.

> We've gotten it to come
> up and mostly working.  Navigating through the repository works just fine.
> The only problem we're having is when we try to use some of the menu options
> like "Add Node".  The dialog box comes up, but whenever you hit Submit, you
> get a green window (dojo I assume) appear in the lower left hand corner of
> the browser with error message "NullPointerException null".  Any ideas on
> what might be the problem?  Or how to debug this?

Not sure what might be. You can debug it by running it inside inside
Eclipse or your preferred IDE. Checkout the project, type mvn
eclipse:eclipse, import it in eclipse, configure the tomcat context
with a plugin (e.g. sysdeo) or manually, run tomcat in debug mode and
have fun :).

btw, a web based jcr browser tool will be contributed to jackrabbit soon.
Not sure but I think it's the content explorer at http://crx.day.com.


> Thanks!
> James
> --
> View this message in context: http://www.nabble.com/jcr-navigator-contrib-project-tf3415783.html#a9518981
> Sent from the Jackrabbit - Dev mailing list archive at Nabble.com.

View raw message