jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jukka Zitting (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-788) Upgrade to Lucene 2.1
Date Mon, 26 Mar 2007 22:00:32 GMT

    [ https://issues.apache.org/jira/browse/JCR-788?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12484243
] 

Jukka Zitting commented on JCR-788:
-----------------------------------

Please do share a patch with your changes. It's always easier to judge a change if the actual
code is available. BTW, would the modified class still work with Lucene 2.0? I also assume
that Lucene 2.1 is compatible with indexes created with 2.0.

I agree that we should try to keep up with Lucene upgrades, but on the other hand I would
not want to force too frequent dependency changes on users. If the change works with Lucene
2.0, then existing users wouldn't need to upgrade their dependencies. If not, then the upgrade
procedure needs to be documented in the release notes.

If there is no immediate demand for the upgrade, I would rather wait until Jackrabbit 1.3
is branched before doing this.

> Upgrade to Lucene 2.1
> ---------------------
>
>                 Key: JCR-788
>                 URL: https://issues.apache.org/jira/browse/JCR-788
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: query
>            Reporter: Marcel Reutegger
>            Priority: Minor
>
> Lucene 2.1 contains a number of useful enhancements, which could be benefical to jackrabbit:
> - less locking on index updates -> less IO calls
> - introduces FieldSelector -> allows jackrabbit to only load required fields

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message