jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Savas Triantafillou" <savvas.triantafil...@gmail.com>
Subject Re: Strange behavior on upgrade from 1.1.1 to 1.2.1
Date Mon, 12 Feb 2007 10:25:49 GMT
Old index contains a file named ns_mapping.properties  inside  index
directory
where new index contains a file ns_idx.properties inside namespaces
directories and ns_mapping.proeprties does not exists

Somehow if these two files exists at the same time queries upon old nodes
are impossible

Restructuring of the index, at least in our case, is mandatory during
migration to 1.2

regards,

Savvas

On 2/12/07, Marcel Reutegger <marcel.reutegger@gmx.net> wrote:
>
> An upgrade from 1.1.1 to 1.2.1 does not require to re-arrange the
> repository
> home directories nor does it required to re-index the workspaces. just
> replacing
> the jar files should be sufficient.
>
> regards
>   marcel
>
> Savas Triantafillou wrote:
> > FYI,
> >
> > I think I have solved the problem but I need to run some more tests to
> be
> > 100% sure
> >
> > Anyway I would like you to give me an opinion of why the following might
> be
> > happening
> >
> > When migrating from 1.1.1 to 1.2.1 I though it would be safer to delete
> ALL
> > directories under the repository home directory, action
> > which created all the problems mentioned earlier in this discussion
> >
> > Then I restore the previous repository home directory and deleted ONLY
> the
> > "index" directories under repository and workspaces
> > directories. And so far all queries are executed OK!!!
> >
> > Do you know why the latter worked ?
> >
> > I would appreciate any explanation as I am using Jackrabbit as a backend
> > for
> > a production system and any insight to how it works
> > will be valuable.
> >
> > Thank you in advance,
> >
> > Savvas
> >
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message