jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Savas Triantafillou" <savvas.triantafil...@gmail.com>
Subject Strange behavior on upgrade from 1.1.1 to 1.2.1
Date Wed, 07 Feb 2007 09:08:44 GMT
Hello,

I have upgraded to version 1.2.1 and manually deleted index files from
repository directory

Jackrabbit rebuilt index without complaining but when I tried to execute a
query no results

were returned.

I have replace the newly created index with the old one and all worked fine

For example queries like

//element(*, my:node) [@jcr:uuid = 'some value']

return results when I am using old index but return no results when using
the new index

In both cases version 1.2.1 is enabled and method session.getNodeByUUID()
works fine

This is the case no matter the criteria.  What is even more strange is that

when I insert a new node in the repository and execute the above query, I
get results with the new index in place !!!!

Any hint at all why this might be happening? Do I need to apply any patch to
Lucene ?


Thank you in advance,

Savvas

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message