jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stefan Guggisberg (JIRA)" <j...@apache.org>
Subject [jira] Commented: (JCR-556) Refactoring of the BackupTool
Date Thu, 22 Feb 2007 11:17:05 GMT

    [ https://issues.apache.org/jira/browse/JCR-556?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12474979
] 

Stefan Guggisberg commented on JCR-556:
---------------------------------------

i agree with jukka's comments, i've got one more:

+    private Statement executeStmt(String sql) throws SQLException {

this is an unneccessary code duplication  of the existing method 
     
      protected Statement executeStmt(String sql, Object[] params) throws SQLException {


just pass an empty parameter array to the existing method, e.g. 

      executeStmt("select * from foo", new Object[0]);


> Refactoring of the BackupTool
> -----------------------------
>
>                 Key: JCR-556
>                 URL: https://issues.apache.org/jira/browse/JCR-556
>             Project: Jackrabbit
>          Issue Type: Improvement
>            Reporter: Nicolas Toper
>            Priority: Minor
>         Attachments: BIO.patch, patch-backup-040906.txt, patch-jr-010906-NodeVersionHistoriesUpdatableStateManager.txt,
patch-jr-010906-PropInfo.txt, patch-jr-010906-RepositoryImpl.txt, patch-jr-010906-SysViewImporter.txt,
patch-jr-010906-VersionManagerImpl.txt, PropInfo.patch, VisitorPattern200207.patch
>
>
> The BackupTool has still some refactoring to perform. I will propose the patch on this
new issue since we cannot change the JCR-442 (Google wants to see a place where all the Google
SoC work is).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message