jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tobias Bocanegra" <tobias.bocane...@day.com>
Subject Re: SPI (jcr2spi) vs JDK 1.5
Date Fri, 06 Oct 2006 15:04:53 GMT
assertions were introduced in jdk1.4

http://java.sun.com/j2se/1.4.2/docs/guide/lang/assert.html

On 10/6/06, Julian Reschke <julian.reschke@gmx.de> wrote:
> Hi,
>
> I just noticed that parts of jcr2spi require JDK 1.5 (for "assert", such
> as in TransientRepository.java).
>
> This would be a problem for me in practice, because (right now) the
> intended target platform for what I'm working on is JDK 1.4.
>
> So could we avoid these dependencies, or do I need to communicate that
> requirement to the people I do my work for?
>
> Best regards, Julian
>


-- 
-----------------------------------------< tobias.bocanegra@day.com >---
Tobias Bocanegra, Day Management AG, Barfuesserplatz 6, CH - 4001 Basel
T +41 61 226 98 98, F +41 61 226 98 97
-----------------------------------------------< http://www.day.com >---

Mime
View raw message