jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Julian Reschke <julian.resc...@gmx.de>
Subject SPI: level 2 support
Date Thu, 26 Oct 2006 16:44:50 GMT
Hi,

I'm currently trying to implement SPI on top of a level 1 store, and see 
(when accessed through jcr2spi):

1) 
testLogin(com.xythos.jcr.BasicSPITest)javax.jcr.UnsupportedRepositoryOperationException: 
level.2.supported is not supported by this repository.
	at 
org.apache.jackrabbit.jcr2spi.SessionImpl.checkSupportedOption(SessionImpl.java:829)
	at 
org.apache.jackrabbit.jcr2spi.SessionImpl.getValueFactory(SessionImpl.java:366)
	at org.apache.jackrabbit.jcr2spi.SessionImpl.<init>(SessionImpl.java:143)
	at 
org.apache.jackrabbit.jcr2spi.RepositoryImpl.login(RepositoryImpl.java:78)
	at 
org.apache.jackrabbit.jcr2spi.RepositoryImpl.login(RepositoryImpl.java:86)

This is caused by the init code for SessionImpl which seems to require a 
ValueFactory.

Is this by design (that is, do I need to support L2 in order to use 
jcr2spi), or a bug?

Best regards, Julian

Mime
View raw message