jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Magnus Grimsell (JIRA)" <j...@apache.org>
Subject [jira] Created: (JCR-609) Empty custom_nodetypes.xml after restart
Date Fri, 27 Oct 2006 16:39:55 GMT
Empty custom_nodetypes.xml after restart
----------------------------------------

                 Key: JCR-609
                 URL: http://issues.apache.org/jira/browse/JCR-609
             Project: Jackrabbit
          Issue Type: Bug
          Components: jca
    Affects Versions: 1.1
         Environment: oc4j 10.1.3
            Reporter: Magnus Grimsell


I run jackrabbit jca on oc4j 10.1.3.
First time the server is started I execute the following code on the empty repository :

JackrabbitNodeTypeManager manager =	
  (JackrabbitNodeTypeManager)session.getWorkspace().getNodeTypeManager();
InputStream nodeTypes = this.getClass().getClassLoader().getResourceAsStream(res);
manager.registerNodeTypes(nodeTypes, JackrabbitNodeTypeManager.TEXT_X_JCR_CND);
session.save();

This works fine. I can create nodes of custom type. However when restarting the server I get
the following error:

Error creating a Connection Factory from class 'org.apache.jackrabbit.jca.JCAManagedConnectionFactory'.
Reason: javax.resource.ResourceException: Failed to create session: internal error: failed
to read custom node type definitions stored in custom_nodetypes.xml:

custom_nodetypes.xml exists but is empty.


-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators: http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message