jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas " <nto...@gmail.com>
Subject Adding a method to PropInfos
Date Mon, 14 Aug 2006 19:34:45 GMT

In order to restore properly the content of a workspace, I needed to escape
some checks the regular WorkspaceImporter class was doing. I rewrote a
custom Importer with no problem. ( It's basically a copy/paste of the
current importer without the check: it's a short term solution for now but a
working one. We plan to implement a switch to escape all checks in JR

However, I couldn't do the same with the PropInfo class. Therefore I add to
add a restoreApply method, which is the same as apply but without the check.
Maybe I should rename it? I choose restoreApply to emphathise the fact that
it's reserved for the restore operation.

What do you think?

my blog! http://www.deviant-abstraction.net !!

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message