jackrabbit-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas " <nto...@gmail.com>
Subject Re: can't Import a system view using ImportXML
Date Tue, 08 Aug 2006 15:20:02 GMT
It's done. I will patch it later. Basically if a node in the WspImporter is
root, I skip it (but process the namespace still)

On 8/8/06, Nicolas <ntoper@gmail.com> wrote:
>
> Hi,
>
> I agree on this. So basically, I should add in core a test to skip the
> storage of jcr:root tag?
>
> Nicolas
>
>
> On 8/8/06, Jukka Zitting < jukka.zitting@gmail.com> wrote:
> >
> > Hi,
> >
> > On 8/8/06, Nicolas < ntoper@gmail.com> wrote:
> > > When I try to import a whole workspace, here is the exception thrown:
> > > /jcr:root: mandatory child node {http://www.jcp.org/jcr/1.0}system
> > <http://www.jcp.org/jcr/1.0%7Dsystem> does not
> > > exist. I don't understand why it happens and how to correct it: the
> > root
> > > node has children...
> >
> > It seems that the importer is trying to recreate the root node. We
> > should probably add special handling of jcr:root in the importer code,
> > so that importing "<foo/>" and "<jcr:root><foo/></jcr:root>"
(or the
> > equivalent system view) under the root node should both result in the
> > creation of a "foo" node just below the root node.
> >
> > BR,
> >
> > Jukka Zitting
> >
> > --
> > Yukatan - http://yukatan.fi/ - info@yukatan.fi
> > Software craftsmanship, JCR consulting, and Java development
> >
>
>
>
> --
> a+
>
> Nico
> my blog! http://www.deviant-abstraction.net !!
>



-- 
a+
Nico
my blog! http://www.deviant-abstraction.net !!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message